0

401 views
Ok I was wondering if anyone else has this issue. I built a version that worked on the flight deck and tested it I noticed that it was still running slow and decided to optimize the graphics and reduce the size Unity 5 has a compression in the engine that does this now. However, when I did this, w/ the compression I created a build that crashed on the flight deck. It would start up and then it would just quit. So I reduced all the graphics manually and rebuilt the game, it still crashed. Has anyone else experienced this? i would like to get a working product out. 
 
Asked May 20, 2015 06:32 AM

 
I am wondering if it might be the way I am installing it. I am putting the apk in download and then installing it. I am going to try a build and run in unity.
May 20, 2015 07:10 AM
@Robbyn
nope still not running.
May 20, 2015 10:23 AM
@Robbyn
was checking the Unity forums and they say one of the issues could be the Android OS...
May 20, 2015 10:55 AM
Hi Robbyn, did you change some player settings? If so, which settings did you change and changed to what? Sometimes when you change these settings it can cause problems when deploying to android.
May 20, 2015 01:17 PM
@Eric James
it works on my samsung s6 so I don't understand why it won't play on my flight deck. The only think I did change was the name of the build
May 20, 2015 01:21 PM
@Robbyn
For starters, you can't compare the flightdeck to the samsung s6. They have different specs and may require different settings in order to be compiled correctly. From what I understand, it may be a Unity compiler problem. Try deleting the Library and Temp folders in your project folder and open the project in Unity. This way Unity re-generates these essential folders then try compiling to the flightdeck.
May 20, 2015 04:19 PM
@Eric James
If this doesn't work, try re-importing all assets via Assets -> Reimport All on the top menu bar. Some assets might have been corrupted when Unity tries to automatically reimport the assets. If this fails, then try changing the Player Settings: Minimum API Level to the lowest version (Android 2.3.1), Device Filter is at FAT (AR Mv 7 + x86), and Api Compatibility Level to .NET 2.0 Subset. These are usually the settings that typically causes the application to close automatically. If all else fails, can you attach a log from logcat? Hopefully, the log will show us something.
May 20, 2015 04:19 PM

0 Answers

Be the first to respond to this post


Preview

Alert